Using the library in WPF

Mar 25, 2011 at 4:32 PM

Is there any dummyproof tutorial to install de library and use it with WPF?

I use Blend 4, and I installed the lastest ( version of the library, actually I can use the behaviors in Silverlight 4, but I cannot see them in WPF.

Looking around I found:

"In Blend, right-click the References folder in the Projects Panel and select Add Reference... Then add the following assemblies from the download (these are for Silverlight development. For WPF dev, use the bin subfolder assemblies instead)"

But... I don't know how to do that :S, I'm a kind of newbie using external libraries and I'm totally lost!... I mean, I don't know what are the "bin subfolder assemblies" and neither how to use them -_-, or where are they :s...

Please help me. Thanks in advance, and sorry for my english hehe.

Mar 25, 2011 at 7:19 PM

Hi, Sorry that the latest version no longer supports WPF :(

It's just a matter of time, I haven't been able to create the WPF solution and do a little testing. You could fall back to an older version of the physics helper if you want WPF support, but this would be using the older version (2.x) of Farseer Physics.

I think the last version that supported WPF and farseer 2 was this one:


Mar 25, 2011 at 8:08 PM

Ok, thanks, actually I'm going to need it in a couple of months so... Is there any plan to make it support WPF?

Apr 18, 2011 at 9:18 PM

I downloaded the version you posted, now I'm totally lost again. Can somebody tell me how can I use it? And... Do I need to uninstall the newest version to use this one?

Apr 19, 2011 at 12:12 AM

Sorry, the new version still doesn't have WPF support. 

If you are interested in Silverlight or WP7 support, and are looking for info on getting started, I would recommend starting with this video -



May 8, 2011 at 7:42 PM

No, what I wanted to say is, I downloaded the older version which supports WPF, with Farseer 2 (change set 57794), now I'm lost again hehe, I don't know how to use it. Thanks and sorry for my english.

Jun 25, 2011 at 8:38 AM


Any news regarding WPF support? I'm goint to start a new project and if in the near future there will be WPF support it would be worth waiting a bit before starting. Wether or not, you're doing a great job, thanks for the effort!

Jun 27, 2011 at 12:10 PM

Any news on a new WPF version? This is very useful in combination with the Kinect SDK!

Jul 19, 2011 at 3:42 PM

Bump... I actually got the version above converted more or less succesful to framework 4 to use it with the new Surface 2.0 SDK, but ONLY in VS... Blend keep complaining about mismatch in framework version, so I hope for a proper WPF update also...

Jul 20, 2011 at 8:27 AM
Edited Jul 20, 2011 at 9:27 AM

Okay, after I converted to framework 4, I could run the spacesuit-example. I tried to add an image that uses an ellipse for boundary, but that did'nt work, so I just made an ellipse and a brush with the image, which works fine.

If anyone could point me to where the framework version is declared for use in Blend, I could probably tidy it up... If you're okay with running .NET 3.5 the above version 57794 works fine.


EDIT: Stupid me... I ran it with the Surface simulator, and just noticed it does'nt take multitouch... I guess the farseer build used in 57794 is the one before multitouch was implemented :(

Jul 20, 2011 at 5:38 PM

Well I downloaded the version 57794 and there was an install.bat which obviously didn't work because I have Blend 4 and it is for Blend 3, so I opened the bat with notepad and I read which dlls I needed to import in my project. And it worked, but actually that version has some strange behaviours... It seems to doesn't work with paths, only standard figures, and if I rotate them the library undo the rotation... well, strange things in 5 minutes hehe... I hope find some documentation about that version of the library, if you know where can I find it, I'll thank you.

Jul 20, 2011 at 6:18 PM
Edited Jul 20, 2011 at 6:22 PM

Hi Forest... Let me get this right:

You got 57794 working with Blend 4 using .NET 4.0? Are the behaviours available as here:

I also got it running but not in Blend, only in VS2010... I have no problems with paths or standard primitives. Only boundary objects. And yes, rotation, translation and scaling should not be done. I found information about that in various videos on youtube.

I'm basically pushing forward for getting multitouch-support (Surface 2.0), which is not the core of this thread... I've tried going the XNA way, but the same problem arose: no multitouch-support as soon as objects get farseer'ed... Several got it working with Surface 1.0 SDK, but there is no compability between the new and old...

Jul 21, 2011 at 6:46 PM


I got it running in Blend 4 but using .NET 3.5 hehe.

And well, I hope someday have a newer version working in it, but for now I gonna see what can I do with the 57794.

Dec 6, 2011 at 10:46 AM

Hi Entity, 

I am trying to get the changeset 57794 working in vs2010 running on framework 4 . 

And till now , no Success :(

Can you please tell me how you did it ?

Thanks in advance